Forum - TTL triggering

From UCLA Miniscope
Jump to: navigation, search
Overview > Miniscope Discussion > DAQ Software/Firmware > TTL triggering Write a reply

I am trying to start the recording externally with a TTL but unfortunately every time I give the voltage high (~2.6 V) the program crashes. It writes in the log that it is creating the file and crashes.

Any ideas?

Also, is it possible to change the TTL to be in a toggle mode (i.e. one ttl starts and one ends the recording).

Posted by Nikolas on 17 June 2016 at 15:15.


This is the same issue we are encountering!

Posted by Hoogland on 17 June 2016 at 15:49.

Hi Guys,

I am out of town but I will look into this when I get back. I might have modified something in the firmware that caused this issue... Should be an easy fix.

One thing to note: I have only tested this input with a 3.3V high signal. There is a possibility that a higher, 5V TTL, signal could crash the DAQ PCB. Nikolas, it sounds like you tried lower voltages but just in case you haven't, use a voltage divider to drop your TTL signal down to 3.3V.

As for changing the trigger to toggle mode, this can easily be done but I probably won't get around to add this function for a while. If you are interested in adding this function yourself I can point you in the right direction.

Posted by DAharoni (administrator) on 17 June 2016 at 18:16.

Hey Daniel,

Thanks for the response! We also used the specified 3.3 V high signal, which caused the crash.

Posted by Hoogland on 17 June 2016 at 19:03.

Hey Daniel, thanks for the reply. Indeed I tried with a voltage divider (from 5 V to 2.6 V). I also tried with 5V, the board seems to tolerate it, but the crash is still the issue.

As for the toggle mode: indeed, if you could tell me where in the code I can check, I will try to implement it.

Posted by Nikolas on 17 June 2016 at 19:51.